1С: Підприємство + корпоративний чат, як налагодити оперативні сповіщення за 10 хвилин

  1. 1С + корпоративний чат, навіщо?
  2. Який чат обрати?
  3. Як пов'язати ці дві системи?
  4. Що робити, коли не виходить?


1. 1С + корпоративний чат, навіщо?


Наприклад, при створенні замовлення автоматично відправляти сповіщення виконавцю, це значно швидше, ніж через пошту. Чи прискорити узгодження заявок на платежі. Чи повідомити людей про те, що прийшли виписки про платежі з банку.

Було б круто відправляти такі повідомлення відразу в корпоративний чат, потрібній людині.

Економимо час — повідомлення розсилаються відразу з настанням події, немає затримок. Телефон не зайнятий, необов'язково, щоб людина сиділа на робочому місці, повідомлення прийшло в чат і буде прочитано.

Автоматичні нагадування про важливі події — система не пропустить нічого та не забуде повідомити відповідальних за це людей.

Хороша історія — якщо це корпоративний чат, то можна відкрити історію повідомлень та почитати: що, коли, та в якій послідовності приходило. З пошуком, у хронологічному порядку.


2. Який чат обрати?


Про «смаколики» розповіли, тепер про реальне життя. Як це все зробити, бажано найшвидше та якомога простіше?

Вам знадобиться офісний чат MyChat, якщо у вас його ще немає — завантажте безкоштовну версію на 20 користувачів, спробувати вистачить, потім можна розширити ліцензію. Безкоштовна версія функціоналом майже не відрізняється від комерційної, та й тріалу на 30 днів немає, ліцензія не обмежена у часі.

Що ж, завантажили, встановили сервер та хоча б один клієнт, який підключаємо до сервера. Усе це можна зробити на одному комп'ютері, для тесту вистачить "за очі". Встановлюється все лінійно, без зайвих зарозумілих питань. Якщо раптом виникають труднощі, ось довідка з установки:

Як встановити сервер MyChat? (покрокова інструкція)

Як встановити клієнт MyChat? (як встановити та підключити до сервера, офіційна довідка)

У нас зараз запущено сервер та клієнт MyChat на одному комп'ютері:

сервер та клієнт MyChat на одному комп'ютері

Усе готово, можна переходити до наступного кроку. Як відправити повідомлення з 1С прямо в офісний чат?


3. Як пов'язати ці дві системи?


Нам знадобиться два файли:

  1. Компонент для 1С,
    C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\1C\8.xx\mychatvk.dll, зроблено за технологією NativeAPI.
  2. Бібліотека MyChat Integration API,
    C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\MyChatIntegrationAPIDLLs\x32\mychat.dll

Беремо ці дві dll-бібліотеки та вкладаємо їх в папку \bin встановленої 1С (C:\Program Files (x86)\1cv8t\8.3.5.1248\bin\).

Тепер відкриваємо тестову конфігурацію 1С та пишемо туди ось таке (у мого комп'ютера з працюючим сервером MyChat IP адреса 192.168.10.107, а користувач, якого я зареєстрував, UIN=2), а ви впишіть свої дані:

    Перем КомпонентMyChat;

    Процедура ПоказатьТекстСтатусаНажатие(Элемент)
        ТекстСообщения = ТекстСтатуса + Символы.CR + Символы.LF + "Вторая строка";
        // адрес сервера, номер порта, ключ Integration API, отправитель, получатель, текст сообщения
        Результат = КомпонентMyChat.SendPrivateMessage("192.168.10.107", 2004, "iddqd", "0", "2", ТекстСообщения);
        Сообщить(Результат); // результат работы функции
    КонецПроцедуры

    Процедура ПриОткрытии()
        Сообщить("Версия MyChat.dll - " + КомпонентMyChat.GetMyChatLibVersion());
        Сообщить("Дата MyChat.dll - " + КомпонентMyChat.GetMyChatLibReleaseDate());
        Сообщить("Версия MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibVersion());
        Сообщить("Дата MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibReleaseDate());
    КонецПроцедуры

    Результат=ПодключитьВнешнююКомпоненту("mychatvk.dll","MyChat", ТипВнешнейКомпоненты.Native);

    Если Результат Тогда
        КомпонентMyChat = Новый ("AddIn.MyChat.MyChatClass");
        Иначе Сообщить("Ошибка подключения mychatvk.dll!");
    КонецЕсли;

Набираємо повідомлення, натискаємо кнопку «Показать» та вуаля:

Результат виконання команди в 1С

Що взагалі відбулось?

Ми натиснули кнопку в 1С, відпрацювала процедура, «підчепила» функцію компонента, вона ж у свою чергу, через MyChat IntegrationAPI вже відправила особисте повідомлення від імені робота, вбудованого в месенджер — реальній людині.

Можна й не від імені робота, але так простіше, адже у нас поки що немає користувачів, конфігурація тестова.

Зрозуміло, що в прикладі все поверхнево та максимально просто, але для тесту та розуміння, як воно працює — достатньо.

Варто зауважити, що повідомлення відправляються надійно, MyChat працює за схемою клієнт-сервер. Можна відправляти повідомлення тим людям, яких немає у мережі. Можна пов'язати в корпоративний чат розкидані містом чи країною підрозділи, можна відправляти повідомлення масово, з обов'язковим підтвердженням прочитання. Є усілякі «смаколики», але то вже теми для окремих статей.

Обов'зяково подивіться довідку з інтеграції офісного чату MyChat та 1С: Підприємство, хоча б мимохідь.


4. Що робити, коли не виходить?


Хто нічого не робить, той ніколи не помиляється. Якщо щось зламалось чи не працює, а розібратися з якоїсь причини власноруч не виходить — пишіть на форум підтримки MyChat. Там чуйні, адекватні люди. Вам завжди оперативно дадуть відповідь та спробують допомогти.

Служба поддержки