1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

  1. 1С + корпоративный чат, зачем?
  2. Какой чат взять?
  3. Как увязать эти две системы?
  4. Что делать, когда не получается?


1. 1С + корпоративный чат, зачем?


Например, при создании заказа автоматически отправлять уведомление исполнителю, это гораздо быстрее, чем через почту. Или ускорить согласование заявок на платежи. Либо уведомлять людей о том, что пришли выписки по платежкам из банка.

Было бы круто отправлять такие сообщения сразу в корпоративный чат, нужному человеку.

Экономим время — уведомления рассылаются сразу же по событию, нет задержек. Телефон не занят, необязательно, чтобы человек сидел на рабочем месте, уведомление пришло в чат и будет прочитано.

Автоматические напоминания о важных событиях — система не пропустит ничего и не забудет уведомить нужного человека.

Хорошая история — раз это корпоративный чат, то можно открыть историю сообщений и прочитать, что, когда и в каком порядке приходило. С поиском, в хронологическом порядке.


2. Какой чат взять?


Про «вкусности» рассказали, теперь о прозе. Как это всё сделать, желательно побыстрее и попроще?

Вам понадобится офисный чат MyChat, если у вас его ещё нет — скачайте бесплатную версию на 20 человек, «на попробовать» хватит, потом можно расширить лицензию. Бесплатная версия по функционалу почти ничем не отличается от коммерческой, да и триала на 30 дней нету, лицензия не ограничена по времени.

Итак, скачали, установили сервер и хотя бы один клиент, подключили клиент к серверу. Это всё можно сделать на одном компьютере, для теста хватит вполне. Ставится всё линейно, без умных вопросов. Если вдруг возникнет заминка, то вот руководства по установке:

Как установить сервер MyChat? (пошаговое руководство)

Как установить клиент MyChat? (как поставить и подключить к серверу, официальная справка)

У нас сейчас запущены сервер и клиент MyChat на одном компьютере:

Сервер и клиент MyChat работают на одном компьютере

Итак, всё готово и можно переходить к следующему шагу. Как отправить сообщение из 1С прямо в офисный чат?


3. Как увязать эти две системы?


Нам понадобится два файла:

  1. Компонент для 1С,
    C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\1C\8.xx\mychatvk.dll, сделан по технологии NativeAPI.
  2. Библиотека MyChat Integration API,
    C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\MyChatIntegrationAPIDLLs\x32\mychat.dll

Берём эти две dll-библиотеки и выкладываем их в папку \bin установленной 1С (C:\Program Files (x86)\1cv8t\8.3.5.1248\bin\).

Теперь открываем тестовую конфигурацию 1С и пишем туда вот такое (у моего компьютера с работающим сервером MyChat IP адрес 192.168.10.107, а пользователь, которого я зарегистрировал, UIN=2), а вы впишите свои данные:

    Перем КомпонентMyChat;

    Процедура ПоказатьТекстСтатусаНажатие(Элемент)
        ТекстСообщения = ТекстСтатуса + Символы.CR + Символы.LF + "Вторая строка";
        // адрес сервера, номер порта, ключ Integration API, отправитель, получатель, текст сообщения
        Результат = КомпонентMyChat.SendPrivateMessage("192.168.10.107", 2004, "iddqd", "0", "2", ТекстСообщения);
        Сообщить(Результат); // результат работы функции
    КонецПроцедуры

    Процедура ПриОткрытии()
        Сообщить("Версия MyChat.dll - " + КомпонентMyChat.GetMyChatLibVersion());
        Сообщить("Дата MyChat.dll - " + КомпонентMyChat.GetMyChatLibReleaseDate());
        Сообщить("Версия MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibVersion());
        Сообщить("Дата MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibReleaseDate());
    КонецПроцедуры

    Результат=ПодключитьВнешнююКомпоненту("mychatvk.dll","MyChat", ТипВнешнейКомпоненты.Native);

    Если Результат Тогда
        КомпонентMyChat = Новый ("AddIn.MyChat.MyChatClass");
        Иначе Сообщить("Ошибка подключения mychatvk.dll!");
    КонецЕсли;

Набираем сообщение, жмём кнопку «Показать» и вуаля:

Результат выполнения команды в 1С

Что вообще произошло?

Мы нажали кнопку в 1С, отработала процедура, «дёрнула» функцию компоненты, а та, в свою очередь, через MyChat IntegrationAPI уже отправила личное сообщение от имени робота, встроенного в мессенджер — реальному человеку.

Можно и не от имени робота, но так проще, у нас ведь пользователей-то нет ещё, конфигурация тестовая.

Понятно, что в примере всё линейно и максимально просто, но для теста и понимания, как оно работает – достаточно.

Надо сказать, что сообщения отправляются надёжно, MyChat работает по схеме клиент-сервер. Можно отправлять сообщения тем людям, которых нет в сети. Можно увязать в корпоративный чат разбросанные по городу или стране подразделения, можно отправлять сообщения массово, с обязательным подтверждением прочтения. Есть всякие «полезности», но это всё темы для отдельных статей.

Обязательно посмотрите справку по интеграции офисного чата MyChat и 1С: Предприятие, хотя бы мельком.


4. Что делать, когда не получается?


Кто ничего не делает, тот никогда не ошибается. Если что-то поломалось или не работает, а разобраться почему, самому никак не выходит — пишите на форум поддержки MyChat. Там отзывчивые адекватные люди, вам всегда оперативно ответят и постараются помочь.

Служба поддержки