Здесь вы можете задать любые вопросы по MyChat, по работе программы, её настройке, лицензированию и т.д.
Аватара пользователя
Petrovich
В MyChat действует общее правило:
1.Все клиенты, которые используют прозрачную авторизацию в домене, должны обновляться через групповые политики домена (GPO).
2.Остальные клиенты могут автоматически обновляться прямо с MyChat Server, через внутреннюю систему обновлений


Возможно ли узнать, откуда растут ноги у этого правила.
Почему именно так?
Аватара пользователя
Алексей Пикуров
Здравствуйте.

Это правило не догма, если вы хорошо понимаете, что нужно делать. Если вы ставили MSI пакет через групповые политики, то он устанавливается в Program Files и для обновления нужны повышенные привилегии, которых у обычных пользователей нет. Отсюда требование разворачивания новых версий через GPO.

С другой стороны, вы могли устанавливать MyChat Client в профиль пользователя, обычным инсталлятором. Тогда проблем с правами нет и вы можете обновлять клиент со своего сервера, автоматически.

Прозрачная авторизация, если вы ее используете, включается просто записью в реестре.